JTechDev

Java 7 for Mac OSX 10.6 (leopard)

So, Apple decided to stop supporting java on their systems, but that did not stop Oracle.  Oracle has made Java 7 work on Mac OS X 10.7 and above.  What does that mean for Leopard users though?  It means that they will no longer test it and create installers for getting it on Mac OS X 10.6.  Well, there is a simple way to fix the first problem, and that is to test it yourself.

The second one is a little harder.  I ended up taking the installer they supply for OS X 10.7 and changed the variable of if it should run on 10.6 and below to a warning.  That worked perfectly on Mac OS X and so far I have not had any problems.  You can download the revised installer here.